login

online now

We have 75 guests and no members online

search

 
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Ummm...can't find Tweaker exe, sorry

Re: Ummm...can't find Tweaker exe, sorry 3 years 11 months ago #416

An update (sigh) - flushed with success, I sat down for a serious Tweaker session, only to get the fabled 'GinSing not found' error. This was on both 32bit and 64bit machines, with the Uno and Mega. All that had changed was that each machine had been shut down overnight and started up th following morning. So looks like there's something weird going on and maybe my view that Tweaker works with the Uno but not the Mega was too simplistic - sorry if I led anyone astray.

But some good news: I dug around and downloaded Soundgin which is a little flakey on the 64bit machine but in general works well enough, and every time (so far!). So if anyone has the problems I did it may be worth trying this path. And I know Soundgin isn't supported anymore, but I'm going to ask a question anyway, maybe someone will take pity on me... Is it possible to copy the register settings from Soundgin and load them into GinSing via TweakerLoad after reformatting them appropriately? I had a quick go but couldn't get it to work: the sketch seems to run OK but no sound output: the obvious difference being that the sample (from Tweaker) array has 143 elements whilst the Soundgin one has 144. Any advice from lurking diehard Soundgin experts much appreciated.
The administrator has disabled public write access.

Re: Ummm...can't find Tweaker exe, sorry 3 years 11 months ago #418

It might be worth a try to run Tweaker from the command line to see what errors it expels. My guess is it might be a locked serial port from a previous run or something? I have seen this on a Mac and simply removing the lock file fixes it, but I don't know if its a similar situation for a PC.

The register setup should be identical, but some register sets get overwritten as they contain state information ( for example the ADSR state bits ). I'm not sure whay Tweeaker is missing the 144th, and although I would not expect that to make a difference, you could set that one manually if you know the value.
The administrator has disabled public write access.

Re: Ummm...can't find Tweaker exe, sorry 3 years 11 months ago #419

You're right again (of course!). Digging a little deeper, when I fire up Tweaker from the command line I get the usual rxtx mismatch warning, then the GUI displays. Then when I select the serial port in the GUI I get the Invalid Response/Port in Use errors in the cmd line. So essentially I did this:
1. Loaded PC Link onto the Uno
2. Added the 10uF capacitor
3. Shut down the PC
4. Restarted the PC with the Uno still connected to the USB port
5. Opened the console and ran Tweaker from the cmd line
6. Worked fine! Drank beer, fell over etc.

I'm not sure what was locking the port (I'm guessing the Arduino IDE) of if the Mega will now work, and won't get back to this for a few days now, but will report back when I do.

Soundgin: turned out it was just that the registers hadn't updated properly before I pasted them into TweakerLoad. Opening a pre-saved Sondgin file and using that as the basis of my new patch worked fine. Hard to work out which register is missing in Tweaker (the 143 vs 144 issue) but hey it works so I'm probably just going to use the 'if it ain't broke' approach...
The administrator has disabled public write access.

Re: Ummm...can't find Tweaker exe, sorry 3 years 11 months ago #421

So I finally got back to this and the story seems to be that the Arduino IDE is locking the COM port so Tweaker can't use it. This isn't too surprising given that my typical workflow was:
  • Open Arduino IDE, upload PCLink to board
  • Close Arduino IDE
  • Add 10uF capacitor to board
  • Open Tweaker

The rxtx library mismatch error seems to be a red herring.

At this stage I have to restart the PC after loading PCLink in order to use Tweaker. I had a quick search for a Windows 7 utility that releases all locked COM ports, but no luck so far, so if anyone knows of a solution I'd be happy to hear it! Nothing obvious using Device Manager etc.

BTW even using the restart approach I still can't get Tweaker to work with the Mega board.
The administrator has disabled public write access.

Re: Ummm...can't find Tweaker exe, sorry 3 years 11 months ago #422

Ahh, that sounds reasonable. Unless you are switching Arduinos connected to the GinSing, you only need to upload the PCLink program once. Each time you turn it on the PCLink program will be there ready to be plugged in a running. In short, you can ship the IDE step unless you are reprogramming the Arduino for other uses.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.361 seconds